PC - Xbox One Controller - Issues


I play SpinTires primarily with a genuine Xbox One PC controller. Lately, I've noticed an issue in the game, it affects the map and advanced vehicle menu.

When I open the map, I'm unable the move the cursor using the d-pad, I can't move right onto the map to clear/move waypoints, I can't move up/down the vehicle list, any presses see the cursor move, then instantly reset to the top vehicle on the list.

I assumed this was the Steam "gamepad as mouse emulation" so I turned off the XBox Controller config.

On next launch of the game, this appeared to work, when I first entered the map I could move the cursor around as expected, then the same issue came back.

Things I've done:
-cleared my steam controller configs under C:\Program Files (x86)\Steam\userdata##########\config\controller_configs
-turned off the Xbox Controller Emulation in steam

I've found one workaround that has sort of worked. If I launch the game with the controller turned off, then turn it on in-game, so far it is working as expected.

Any ideas?

Thanks in advance for the assistance.

I'm not sure I quite understand the issue you're having on the map, you're unable to jump between the waypoints, but only while moving right? Are you able to do this using the analogue stick?

Thank you for the reply, apologies for my poor explanation.

When playing with an Xbox Controller and in the game map, you zoom/rotate the map using the right analogue stick, this works fine. You pan the map using the left analogue stick, this also works fine. Waypoints are added via the shoulder buttons, this also works fine.

You navigate the left-hand vehicle list, or the waypoints on the map using the d-pad, it is this function that is not working.

When I open the map, the mouse cursor is snapped to the first vehicle in the lefthand list, normally I will be able to move up/down that list using the d-pad, or be able to move that cursor to the map on the right to then interact with any set waypoints.

When I try to move the cursor using the d-pad, it moves, then snaps back to the first vehicle on the list. During that time the controller tooltips also flash and I swear it shows the keyboard tooltips for a second.

I thought I have found a workaround last night, I launched the game with my controller turned off, turned on the controller once the game had loaded, entered the map and it worked as expected. However, after exiting back to the game, driving to the end of my set waypoints, I tried to use the map again and had the same issue.

Does the controller work normally in other games?

Yes, I play the Witcher with it on GOG Galaxy and ME 3 through Origin with it.

However, you've given me an idea.

When I'm playing other games in through other clients, I have to turn off Steam or the controller just acts weird.

Thinking of this, and the flashes of the tool-tip in Spintires showing the keyboard tips makes me think this is related to the Steam allowing you to use a controller that will emulate keyboard/mouse.

As an example, I can move the mouse cursor when outside of games and the Steam client running by using the right stick, the right trigger then acts as the left click.

It's a pitty I can't test SpinTires with Steam off to confirm....

I was able to test the above hypothesis, and it did not pan out.

I found out how to turn off the "mouse emulation via the controller" in Steam and tried the game again.

The same issue persists, it also partially affects my ability to use the advanced menu as well.

When playing and trying to release the winch I have to either quickly hit the d-pad and A to release, or I end up with the cursor being snapped to one of the menu items.

I can attempt to take a video to better show this if needed.

This is for Spintires: MudRunner, right? Not Spintires?

Not sure I had exactly same problem but this helped to solve most issues where mouse was fighting with controller.


i made a report a while back when Mudrunner came out same problem, and still persist with the combination pad mouse keyboard it doesn't work properly when you want to navigate the ui.
An other instance where it s really annoying when you want to pinpoint a place to winch after pushing y on the controler then switch to the mouse to see the advanced menu close itself,i fixed that a while back too,but it wasn't easy and now everything is gone due to the patchXD.
Didn't try that tweak mentioned in that link though but sometimes i m kind of tired to have to resort to a whole list of things to tweaks to be bable to play properly a games this days.

last edited by Raphael