Version not updating

This isn't a support request as such, more of a request for information, I apologise if this is in the incorrect place.

My version of STMR appeared to update last night via Steam (i.e. downloaded content and overwrote the modifications), but in-game the version still states the December version.

I tried to validate/verify the files thinking that they haven't updated properly, only for the same thing to happen again. I also cleared the cache with no change. I think it has got something to do a modded file somewhere in my Media folder, which is something I can resolve myself. I tweak some of the class xmls in the, which I also believe could be causing the issue.

For the moment though, I am not too worried about updating the game as I don't use the workshop, but for future reference, is anyone able to confirm which files could potentially cause this issue in the, or anywhere for that matter, so that I can copy the previous classes that I've edited to the latest version without causing this type of problem to occur again?

last edited by Kingpinn

Are you maybe on a beta version in the properties?

This is a question I need to start asking as well, thank you, @Mexican_420 🙂

@iyagovos and @Mexican_420 , thanks for the replies. I didn't opt-in for the beta, and I don't use the STmod.

last edited by Kingpinn

What happens if you re-install the game?

@iyagovos thanks again for your reply. When I update the game, Steam goes through the motions; it downloads the updated and the files in the root directory get replaced. I then load the game and its the same as it was before the update with previous third party maps working and workshop maps do not appear in the map select menu.

I didn't get a chance to check last night, but I will try again later without the Media folder in the config and see if that stops it.

The strange thing is that the game has updated since December last year, but the December date is present in the main menu screen. The DLC works as it should too.

Could you please screenshot the main menu of the game, for me?

So you have all the additions from the future patches? The Valley wasn't released until February, so this is a little odd.

Also, could you please screenshot:

  • Properties>Updates tab
  • Properties>Local Files tab
  • Properties>Beta tab
  • Properties>DLC tab

Could you also try going to Steam>Settings>Downloads and clicking "Clear Download Cache"?

last edited by Iyagovos

The download cache thing was the issue. its now updated. Thanks for your help.

Brilliant, thanks for letting me know! Enjoy!

I appear to be having the same issue again. This time its the March version thats showing.

I've tried the following:

  • Verified game files
  • clearing steams download cache, then verified the game files
  • clearing the games cache in the app data folder

each time it appears to still show the March update version in the main menu.

last edited by Kingpinn