Texture issues with AMD GPU

Hi there,

Here are my PC's specs:
i9 9900k
MSI Z390 Pro Carbon
2x32gb ddr4 3600 cl 18
Samsung 970 Evo Plus 2TB
LG 1440p 144hz monitor.

Windows 10 Pro:
Version 10.0.19042 Build 19042

Radeon Drivers:

I'm seeing very odd ground textures that are black, in every map. They constantly move as my point of view/camera moves. Friend of mine also has a 6900xt with the same issue. I've tried DDU to wipe AMD drivers and do a clean install, didn't help anything I could notice. Screenshot 2021-02-05 213932.jpg

It probably would have been better to bump any one of dozens of other threads on this, here's just three of the most recent: 1, 2, 3.. This has been an issue issue since Vega, manifests on RDNA 2 GPUs as well (and is even worse there), can not be mitigated by any in-game, or driver setting. NWI is either oblivious, unconcerned, or doesn't know how to reconcile the issue -- as it's been documented here and on the Steam forums for -- over two years... The issue manifests much like texture z fighting but only on terrain, is not just distractingly hideous but can actually make the game unplayable as very large areas can get blacked out. This seems really like a real dumb area level design as this is the only Unreal Engine game where this problem manifests -- it never happens in Ground Branch, Squad, Red Orchestra, World War 3 which also do LSS terrain, or any other Unreal Engine game...

last edited by Hoak

More than a little sad to see this ignored for so long... Especially with the popularity and greater availability of new AMD GPUs; a reasonable assumption would be this is an eye sore that NWI would/could not afford to ignore.

If anyone is aware of any mitigation in low level settings, or fix using tools like reshade or similar it would be greatly appreciated.

The people that are posting this here, on the Steam, and AMD forums, and complaining in-game are far from 'few and far between' and would greatly appreciate the help, or consideration of a reply from NWI...

last edited by Hoak

Finally found a fix: forcing DirectX 12 will get rid of the z-fighting, it's silly but it works. Just add "-dx12" to Steam's launch options:

alt text

This also may even offer a performance boost on lower end NAVI and Vega GPUs with newer drivers depending on the card you have, preferred render settings and resolution you're driving...

Hope this isn't too late to help NAVI and Vega users frustrated by the horrific render issues under the default DirectX 11.

last edited by Hoak