Fallen titans problem

Second log don't register when dropped in rail car! Now the third log isn't revealed on map. Unable to complete contract.

@bushwacker Hello, it's SnowRunner Support. Thank you for the report. We are sorry you had to face this problem.
Can you please add the screenshots (a short video if possible) to see the issue and a KSIVA code (in the bottom screen, might be enabled in the settings) for investigation?


@NetRunner If I'm in a truck on grainwoods River and go on the map in black badger lake I can see the sequoia log on the map but when I switch to a truck in badger lake it's gone! I've been to the location and the 3rd log isn't there although on the map it looks like it's floating in the air bit I can't see it anywhere.

last edited by A Former User

@bushwacker Thank you for the picture!
Could you please take a screen from the map to see it floating?
After that, please try to restart the contract.

@NetRunner there's a service spare parts floating near it as well.

@bushwacker Thank you very much for all the information provided, but could you please also attach your PTS storage folder?

It will help the investigation a lot (you may archive it on any cloud storage) : C:\Users\username\Documents\My Games\SnowRunnerBeta\base\storage

last edited by NetRunner

@bushwacker this is something that happens when you are on a mission and you look at another map which does not actually have them items on it.... the log you see on the Black Badger Lake map when you are on Grainwoods map are actually a ghost image from the Grainwoods map that you are on, look on the Grainwoods map and you will see the Sequoia log to pick up..... also on the first picture once you drop the log in the train car you have to then go to cargo management and store it in the cart as shown on your screen shot "C Cargo Management"

I'm jumping in a few months later.
We are having the same issue in the current build (version 15 on Epic Store).

We are in a Co-Op game. Nor Host nor Client could make a difference.

The first Sequoia trunk will not trigger when dropped in the train wagon.
We do not get the Management prompt.

alt text

alt text

last edited by Thisdale

@Thisdale I have same problem. Solo play. Task restart didn't help.

The first one is not registered. Cargo management simply does not appear.

Same exact thing has happened to me, have they broken something? I'm on Xbox Game Pass on PC.

Quick update.

We relaunched the game and both player tried to retrigger the prompt (host and client).
We reset the mission, same result at train. No prompt.

We're pretty much screwed now. Will need help from the dev to fix/hack this.

I’m having the same problem, after loading the first sequoia no cargo management prompt!
Playing solo on Xbox One with the latest game update.
Tried restarting the contract, game and console to no avail.

I have the same problem on this mission. Without prompt to deliver the first sequoia (Xbox One X).

@Thisdale I have the same problem on this mission. Without prompt to deliver the first sequoia (Xbox One X).

I had the same issue on ps4 no context button for "Cargo Management" reset of misson is not working. This issue is not cool cause i need this mission to get foword. Please fix it.

Found a mental fix, you need a vehicle in the yellow load box. Crane a Scout in and then switch to it. I think the latest patch broke something. I had to do this for all 3 logs but was able to complete the task. Volume{e974c0db-7485-50f5-a18e-da89cfc1d05c} Screenshot 2021.09.12 -

last edited by Cavturbo

Exact same issue, Xbox series X, solo.

Luckily I showed up here a few hours after Cavturbo posted his work around which also worked for me!