PTS Update 13/10/2020 (10.2)

Hello SnowRunners!

We have another PTS update for you today, bringing a whole host of fixes and even some preparatory changes for mods on consoles. Keep in mind that mods will not be coming to console in Phase 2 (the upcoming update), but after that.

Another important note: With this update we're introducing changes to our mod packaging system that prepares for mods on consoles. Therefore, mods will not work on this PTS, unless they are repackaged to work on it. Doing so will break them on the live build, so if you're eager to be prepared for when Patch 10 goes live, you could prepare it ahead of time, but not apply the changes on until patch 10 goes live.

We will speak about the selection process for mods later down the line (The eligibility requirements for console mods are stricter than on PC).


  • Fixed missing timer for "Ride on King" trial
  • Fixed a bug where the contract stage with the labor force was not considered completed when the required number of cabins has been delivered to the 'Cabin Zone' active zone
  • Fixed a bug where control point's icon disappeared after restart of the Long Ride contest
  • Mod creators are now able to choose whether they have a dev menu or not
  • Fixed a bug where the value of the cargo amount in 'Craft' zones was not synched between player in coop session
  • Fixed a bug where a truck could be discovered again after every restart of any task for truck delivery


  • Fixed a bug where the crane controls button did not match the control prompts at the bottom of the screen
  • Fixed a bug where a number of required labor force was displayed differently on the map and the objective for some contracts
  • Fixed a bug where the factory was not marked on the map in Pedro Bay
  • Added background images for Yukon maps on a global map
  • Added loading screens for Yukon maps
  • Fixed a bug where the player opened the store in the garage and tried to change the category of a truck with buttons Q/E with keyboard or RB/LB with a gamepad, he could only see 3 categories
  • Fixed a bug where objective markers did not appear right away on the minimap in Kola Peninsula maps
  • Fixed a bug where the quest marker on Cat TH357 during the Loader - Operation Training task remain after any player moved to this truck in co-op
  • Fixed a bug where it was possible to totally zoom out and observe the entire map in 3D
  • Fixed a bug where some default upgrades could be completely uninstalled and sold
  • Fixed a bug where icons for the loading zone of task "Magnitude 5" did not appear on the minimap
  • Fixed a bug where landmarks of buildings before and after construction were mixed up on the minimap on 'Drowned Lands' and 'Zimnegorsk' level, Taymyr

Mod Browser

  • Filtering and sorting settings are now saved
    Improved “All Mods Have Been Downloaded” pop-up
  • Supported ability to enable/disable all subscribed mods
  • Players can now subscribe and activate mods with mouse click


  • Fixed floating lamp next to the warehouse in Salmon Big Peak
  • Fixed a bug where the fence was breaking when driving near it in Salmon Big Peak
last edited by Jellyfoosh

Why is the font size of the main menu smaller. Want me to bring two glasses to see the menu?
And now, can I play with my own mod without uploading
Can you hide the hint of the crane by default? And when the crane is lifting an object, how can the rope of the crane winch not be disconnected when it is switched to another vehicle?

When can I ship the logs to make money? Don’t pack the logs once they’re loaded. This is true.. I don’t like challenging tasks to make money..

Sorry i don't know english

last edited by cement road

Thank you for this update.

I report another bug, present since the release of the game, already reported notably by email, which remains to be fixed: the keyboard key mapping for AZERTY keyboards corresponds to QWERTY keyboards :

2020-10-13 15_22_40-SnowRunner __  KSIVA_ p_ed8a9.jpg

(here WSAD is ZSQD on Azerty keyboards)

last edited by A Former User

Happy to see that there is still a focus on bug closure, seems the team is now able to focus on the nice-to-have fixes! Thanks devs.

Please bring the tool bar back for the custom maps


Guess the other way round when mods will not get updated they will not shown in game, right?
What if we have bought a truck or a trailer?sell for safety?

@Scaniadriver1983 said in PTS Update 13/10/2020 (10.2):

What if we have bought a truck or a trailer?sell for safety?

Sure, I'd like an idiot's guide on that myself.

Probably best to start a new game.

Hmm found a bug. Tried to disable all my mods through the mod browser, but after clicking around a bit, the control hints in the bottom right disappear and then the esc key no longer works to exit the browser. Had to alt+f4 the game at this point.

@ksxkshan said in PTS Update 13/10/2020 (10.2):

Probably best to start a new game.

On live game ~ in testing I did start a new game ~ you know, I'm going to say that it's not a realistic option.

I've had so much problems with mods that I personally banned them all ~ recently, I'd have to find my post again, but I declared mods working on both saved and PTS games.

Now, it seems like all those problems are going to be released again.

So I really don't understand ~ which is why I'm looking for an idiot's guide. 🙂

@gbeeTen For sure, live game should not expect you to require a new game.

But for PTS, I doubt they are writing the code to automate the upgrade of save games, etc. to the new version until it is fully figured out. So for the PTS, sometimes a new game will be the only answer.

@gbeeTen same here, man... Crashes when switching maps, etc...interesting thing now no more problems anymore

Only a few pickup trucks and the fuel trailer for trucks left.
Hmm we will see... Better complete mod clean

I've been attempting to complete the contract for restarting the gold mine, rehabilitating the conveyor belt, and fixing the ore sorting facility. I've run out of concrete slabs. There are none left on either map.

Will a future update provide a source for more concrete slabs? There is a concrete plant in "Flooded Foothills" just to the west of the garage. Will this become a source for concrete products?

Thus far, I'm not a fan of the limited supplies, and having the supplies spread out all over the map (bricks and wooden planks).

Great and fast job guys, thank you!
Do you have a plan to do something with flying trailers? Still hitting my cars when i come close...

Im just scared for when the 10.x will hit live... i anticipate a chaos...

Great update! But am I the only one not to be able to open the storehouse? When I step on it, it displays "(X) Open Storehouse", but after pushing X, nothing happens. Looks like it enters some mode, without display. I have to press on B to exit this invisible mode and continue, but no crafting is possible.

Youtube Video

last edited by eDonan


Look here, how to use the craft...

I had the same problem... leaving game may fix this, but after I leave and restart, warehouse was empty (before I put thinks to craft in it).

last edited by Fratzegeballer

@Jellyfoosh said in PTS Update 13/10/2020 (10.2):

Fixed a bug where the player opened the store in the garage and tried to change the category of a truck with buttons Q/E with keyboard or RB/LB with a gamepad, he could only see 3 categories

gold mine drop point yellow boarder missing , will not let you drop loads now

@Jellyfoosh so if we are only using mods we got in the snowrunner selections are we safe oooooor idiots guide maybe ?
my mods are working fine in 10.2 patch.

forklift falls off trailer way to easy. while packed or chocked
goldmine drop point are the only 2 bugs i see at the moment last 2 patches huge improvement

I discussed this issue with esorokin on discord but just wanted to update some more info I have found. Since the 10.2 none of the custom maps will load either local file or from modio browser. After further testing I was able to get a garage map working that did not have task or loading zones so the issue may be there. I deleted the trailer store and the cargo loading zone off my map and it now loads properly.

last edited by Smed1981