Cannot play any modded maps anymore after update.

First thing, thanks for all the work you are putting into this game.
I run a server for some friends and after the latest update We can no longer play any of the modded maps. When loading a map we all get a pop up titled Sterilization Error and have to bring up the task manager and kill the client. The server seems to keep running.
We have tried deleting and rebuilding the modio folders on the server and the clients but that did not help. Currently we can only play original maps which is boring.
Does anyone have any answers or help? Is anyone else seeing this?

Remove all modio folders and remove the id’s of all mods then go to modio website and only add id’s of mods that been updated to 1.71 also remove all mods from your client side and verify your game files

Since when does the mere presence on the file system of out of date mods break all mods completely? What is going on with the mod support in this game? Becoming more trouble than it is worth.