Dedicated server issues since 1.7.1

Hi Focus Home Interactive,

I run a dedicated server using the Linux binaries on FreeBSD. This has worked fine until the 1.7.1 patch.

Now, the first map loads and plays fine, but when the server switches maps (either at end of round or from the admin menu), clients load to 94% and it gets stuck there. In the server console, I see "[ 81]LogEasyAntiCheatServer: [21:40:12][Linux][EAC Server] [Info][Register Client - CCS] Connection failed! Client: 0x8d7a9cd00" over and over and over.

My friends and I like to have a small server just for ourselves. It's how we've played since original Insurgency. If it's not going to work anymore, that's really, rally frustrating.

I'm happy to provide any assistance I can to you.

Delete the -rules=OfficialRules from your startup, delete all mods and mutators and remove Hillside from Mapcycle, that fixed it for me.

last edited by Madman-ultoris

I also have this issue. Server is running on Windows. Vanilla server, no mods, no mutators, official ruleset. Just a couple customisations like bot counts and capture time. Clients stuck loading at 94% but if you wait a bit longer they get to 96% and stay there forever. Nothing obvious in the server console. Happy to assist with logs/console/config files/anything even server access to staff.

Good find. Looks like the only issue for my server was -ruleset=OfficialRules

So I guess that means community XP gain won't work for now?

Thank you so much!

This does let two of my friends connect. However, a third friend who plays under Linux crashes when he connects to my server. And only my server. He can connect to other servers just fine.

I just... I don't know what to do to fix this. I tried redownloading the server and deleting my Game.ini. He just can't connect. He used to be able to, before 1.7.1...

OfficialRules are not a requirement for server eligibility for Stats system as per official Admin Guide.

Users starting the game under Linux (either via WINE or Proton) are doing so on their own risk as this platform is not supported.
Last time I heard it required EAC to be disabled meaning that such clients would not be able to connect to EAC enabled server.
As per your log posted in OP, you are running EAC ?

Since v1.7.1 mods and modded maps may be broken completely so ensure you are not running any.

Thanks for the reply, @Arc.

I've never run mods or modded maps on my server; just regular old Vanilla Sandstorm.

I recognize that Linux isn't supported. However, it was working just fine until 1.7.1, even with EAC. I've tried disabling EAC and my friend still crashes on connect. He can connect to other servers just fine, and I'm assuming most of them haven't changed the EAC settings.

I'm seeing some other issues that I can't explain:

  • My server asks for a password, even though there is no password specified in the startup line. This happens even though I changed my server to a completely different computer and OS, AND installed Sandstorm on a completely different computer. (Before community XP gain, I had the server password protected, but not for months now.) You can type the password I used to use, or you can just press Enter and it will let you in. I don't know why it thinks I have a password.

  • Now my server isn't appearing in the server list. I've gone over my startup script many times and, as I said, I've installed the dedicated server fresh onto a new OS (Ubuntu 20.04 LTS) on new hardware. There is no firewall running.

For what it's worth, here's my startup file, less GSLT of course:
/Shares/Servers/Sandstorm/Insurgency/Binaries/Linux/InsurgencyServer-Linux-Shipping Oilfield?Scenario=Scenario_Refinery_Checkpoint_Security?Lighting=Day?MaxPlayers=4 -Port=28000 -QueryPort=27131 -log -hostname="Hotdog Clan" -GSLTToken=xxxxxxxxxxxxxxxxxxx -GameStats

It's like my server/public IP is blocked from NWI or something. If that's true, then I'd love to know why and I'd love to know how to fix this situation. I opened up a ticket with them a while back, but I'm not really confident that they'll get back to me.

last edited by jrronimo

@Arc wait why are dedicated servers also needed to stand this kernel driver bulls_it?

I mean from a technical standpoint your server should only be receiving heartbeats from client, it does not require you to tamper with the system side of things.

TBH the Linux dedicated server had been pretty problematic from the beginning, I also had this "dangling gamestate" problem where if I ran a lot of games over and over and sometimes when the server reload it cannot load the supposed game mode anymore for some reason, hence "dangling". I kept reporting it and no one responded, at a point I'm so frustrated I stopped hosting servers anymore.

Linux is the most stable server platform, countless devs runs their services on Linux including me, and to the gaming scene, Squad dedicated server is doing great with Linux, SRCDS are also having great Linux support too, so I'm not sure why the tech team at NWI wouldn't like to investigate on those Linux server problems...

last edited by stevefan1999