PTS:Editor:References can't be added


As already described on Discord, I cannot add any references to my map.
I get the following error message every time. But since the .XML file is definitely in the prebuild folder, this error message doesn't make sense to me.
I have the same problem with PTS and the released version of the Editor.


I have already tried the following:

  1. deleted all references and unpacked them again
  2. I have loaded, compiled and saved some references (rebuild terrain)
  3. moved references (.xml and related folders) from their folders (usa/rus/rus3) to the main prebuild folder
  4. I have renamed the references
  5. I have created my own references

I always get the same error, it doesn't matter where the ref_name.xml I want to load is located.
The same error also occurs when I try to open a completely wrong file (.jpg, .dds, .txt, and so on) and/or a file at a wrong location (desktop).

If it is important, the path to the prebuild folder is the following on my system:
"D:\System\Documents\my games\SnowRunnerBeta\Media\prebuild"

So the path is slightly different from the normal "C:\Users\Username\Documents" path. By default Windows saves all my documents on the D:\ HDD instead of the C:\ SSD.
The editor recognizes the correct path and opens "D:\System\Documents\my games\SnowRunnerBeta\Media\prebuild" when I want to add a reference - so there doesn't seem to be a problem here either.
I have even tried to set up a new folder structure with the more common path "C:\Users\Username\Documents\my games\SnowRunnerBeta\Media\prebuild" and tried to load the xml file from there, same error.

I've already worked with the editor in Mudrunner and used references, so I'm not new to the topic, I can't find any errors.

Translated with

Edit: If I add a reference to the level_name.xml by hand, it gets loaded and shows up on my map. So the references work, the preoblem must be something with the editor not identifying the right path/.xml file.

last edited by DerEggen

The latest version of the editor works for me, no problems with adding references.
But I changed my whole system, new OS, new installation of SR and so on. So I don't know why it's working now.
If it doesn't work for you, there is just the work around by adding references by hand.

You need to add this to your level_mapname.xml file, in the reference section:

STG="usa/us_garage_01" <--this is just an example, you need to fill in the right path to the reference
Pos="(0; 0)"

That will add the reference to the center of the map. Please make sure that the reference section in the xml file starts with <References> and ends with </References>. Have a look at the other sections and you will see how that works.
After that you can work with the reference as normal.

thank you,you are very kind,but it doesn't work that way either

Könnten Sie mir bitte etwas mehr Hilfe geben?