PTS Patch Notes 05/06

Hello SnowRunners!

A new build just went live on the Public Test Server. You'll find the patch notes below.


  • Trucks with trailers could fly when the player changed truck
  • Trucks on trailers could fly away when the player attached to the trailer


  • Fixed incorrect/missing wheels bindings


  • Various localization fixes for Japanese, English
  • Missing info on copyright screen
  • Return to main menu confirmation screen was not localized
  • Fixed some visible debug texts
  • Fixed cropped text on fuel gauge


  • Missing info on copyright screen
  • Fixed missing animation skip button
last edited by Jellyfoosh

Hi, when will I be able to update the PTS via epic games store, it’s still 5.4 at the moment!

@offrodo It just started downloading the update on my computer. I guess that updates are randomized to prevent servers overload.

G 27 still not working, other Wheels no preset available

last edited by Dietmar

same here, its like my G920 is unplugged, nothing happens when using the preset and when trying to set it up as custom no commands/inputs are recognised 😞 it doesnt function in the game at all

last edited by offrodo

Здравствуйте! Было бы неплохо сделать какой-либо канал связи в мултиплеере, а то искать оналайн игроков можно, но согласовывать действия никак!(((

No one understand anything no more... what updates are this if the update for 9 june is already sent to be confirmed... and PST will be closed on 9th of june...

And guys... who played PTSas main progression it will have a surprise on 9th june when, instead of continue, youll get only new game option... they said from the begining PTS saves cant be transfered to main game... or maybe im outdated... but thath what they said... dont play PST as main progression! So on 9th of june PTS will be closed... no play no more... no saves no more...

last edited by Nonasing

Completely broke co op for my friends and I. With either of us hosting, when someone else joins both of our games freeze.

Unfortunately, the Wheel G29 still doesn't work in the PTS 5.5 patch. Why don't they get this done now. In any case, the Wheels worked in the 5.3. I understand that it is a test server, would also like to give feedback, but if my Wheel does not work ..... I do not play snowrunner, so no feedback. The idea of ​​the test server is good, but basic items, such as the functioning of wheels should be just fine, after all it worked in an earlier version. Missed opportunity ....... I'm waiting for an update again!

They are patching stuffs kinda chaotic... im sure we will have unpleasant surprises on 9th after the official update...

last edited by Nonasing

I have 60 euros for a game in which the essential functions like the steering wheel steering do not work. This is a major defect that has not been remedied after multiple requests. Maybe you should collectively claim your money back. I'm sorry but slowly I find it a shame because the game itself is good. But if you can't use it, it's a preview and not a game you pay for.

Did you see my thread with the pics of the flying red trailer (happens only to long red ones) attached to the top pipeline in Alaska? Before realize to fix for a patch..

last edited by Meow81

Its strange, it's like devs are lagging one patch, the things we reported for 5.4 is not fixed for 5.5 etc etc, like this bug where you can't left click with mouse in Map menu, no clicking to enter a truck and no clicking to enter garage...i guess well just have to wait and see

Do we need to show the server name (or whatever it is) on screen all the time during play ? Can we not have that as a toggle-able option ?

awesome work. keep them coming!

Yesterday I wrote that my wheel G29 stopped working after the update to PTS5.4. Unfortunately my Wheel G29 also stopped working in PTS5.5. However, after I reinstalled Ghub and completely redesigned it, I can use the wheel again. Strange.......
I just can't understand that the Wheel g29 worked in the PTS4.4 and after an update you have to reinstall and set up the entire Ghub software again and then get the function back. I not hope now that after every update this is the case ..............
Outside of updating the PTS server I did NOT change anything in my PC settings ........

last edited by Ozzy-NL

Thanks, Ozzy-NL, uninstalled G-HUB, Re-installed, now my G920 is working again!,