PTS Patch Notes 02/06

Hi everyone,

Another update to the PTS is now live! See the full changes below:


  • Fixed DLC trucks disappearing


  • Improved optimization when leaving garage


  • To transition to a new region, Host must now accept a prompt which starts a countdown for all players
  • Host was stuck on a warning pop-up when trying to switch region
  • Truck could be lost if client disconnected from the session
  • Collision no longer broken when exiting the garage built by the “Key buildings restoration” contract
  • Buttons in notification about changing regions were missing
  • Guest couldn’t see other players moving after entering in their vehicles


  • Game crashed when trying to bind a key to additional functions in pop-ups


  • Warning message about transition to another region in coop was displayed in English for all languages
  • Fixed various debug strings
  • Fixed English text being used for various other localizations
  • Fixed various localization keys and incorrect names in the customize menu
  • Quotation marks were used instead of apostrophe marks in the “Uplink” contract descriptions


  • Fixed region transition message overlapping controller disconnection warning
  • Fixed player gamertag on minimap disappearing when changing truck
  • Fixed double prompt while clutch button is pressed when using a winch
  • Had to confirm twice in order to transition to a garage in another region after closing a region transition warning
  • The authorization window did not contain links to's Privacy Policy and Terms of Use
  • Garage selection hitbox has been significantly increased when there is at least one truck in the garage
  • Buttons in notification about changing regions couldn’t be clicked using a keyboard or gamepad
  • Fixed double input when trying to buy or sell trailer in trailer store with custom preset
  • Opening the minimap and changing tab just after discovering a watchtower broke the objects list


  • The task “The Great Nomad” could not be completed
  • The task “Ol’ Faithful” could not be completed
  • Fixed camera shake when driving near some banners and signs
  • The contest “Landslide Mapping” doesn't fail when you recover to the garage
  • Fixed inability to activate AWD on gateway or loading zones
  • Refueling from mission trailer was causing the mission to fail
  • Repair progress bar changed to points instead of percentages
last edited by Jellyfoosh

Very good. Hope to fix more problems and update the beta to the official service as soon as possible. Thank you

Any update on when these changes could roll into the Live branch?

Is there a list of known issues still being worked on?

last edited by scramjet

Sounds like good progress is being made to make this live soon. Hoping PC gets it this week as long as it doesn't make anything worse.

What about steering wheels? Many wheels still doesn't work

After latest patch, now my G29 is broken..need to go to settings and randomly assign a key first, then it reverts back to custom setting

@Jellyfoosh after patch can"t choose any wheel anymore other then custom
Jumps from G29 back to custom

Report: Can't click through wheel presets. Neither left nor right button
is working. Windows 10.

Dear @Jellyfoosh
could you please consider to show all
(keyboard) key bindings in SETTINGS/CONTROLS.

"1" to change camera is missing.

Also in the tutorial:
Show a tip how to switch to cockpit view
as long as this button is not revealed.

last edited by MuddyRunner

It is of course now very nice that I have patched so quickly, unfortunately my Wheel G29 is no longer functioning ... pity. Hopefully another hotfix will be added soon. !!!!!
Also cannot set axes and buttons. Resetting all settings does not work either. G29 is completely not recognized. Has functioned well in the 5.3.

last edited by Ozzy-NL

I'm also seeing the problem with wheel presets. Can't even change back to custom preset with the arrows. Have to reassign a key to get it back.

At least the exit crash is now fixed. So one step forward, one step back.

@Jellyfoosh What is the point of the wheel presets anyway? Does anyone use them? I think most people like to customize the buttons on their wheel, myself included. I could use the preset for my wheel that the game now forces on me, but I don't want to. The buttons are not assigned the way I'm used to them. I'd much rather have no wheel presets and have the game allow us to set our own buttons and remember them, like MudRunner did. Why take a formula that worked and make it worse?

last edited by Unster

@MuddyRunner said in PTS Patch Notes 02/06:

could you please consider to show all
(keyboard) key bindings in SETTINGS/CONTROLS.
"1" to change camera is missing.

+1. It's not just the camera key that's missing from the shown key bindings. There's a lot of hardcoded bindings that we can't change. And some of them you can change, but then it breaks other functionality that relies on the original hardcoded binding.


I use the preset and it's great to have one, if you don't want to can just key-binding by yourself

last edited by Agnolini

@Agnolini I'm absolutely fine with the preset (G29).

"Localization" fixes are usually one of the last things to happen before software is finished. Given all the localization fixes, does this indicate that this update is possibly the last test update before release to production? A release candidate version?

any ETA on the COOP not working on the same router ?

@Agnolini said in PTS Patch Notes 02/06:


I use the preset and it's great to have one, if you don't want to can just key-binding by yourself

OK, so some of you like it. I don't have a problem with the presets as long as they don't interfere with my custom bindings. In this case they do. A little more testing would go a long way.

@Orzark THIS oh so very much THIS!

@Orzark said in PTS Patch Notes 02/06:

any ETA on the COOP not working on the same router ?

good news... please also take a look at vehicle sounds! in stereo and 5.1 there is only booming whistling wind noises... no real engine sounds.! please fix this issui, its so irritating after 10 minutes...