How are people managing to even use mods in the first place?

Why do I get this error message whenever I try to join servers running mods?

I try doing what the error message in the title says, but there's zero presence of a sign in button or anything that would indicate as such.

I've tried:

  • verifying game files
  • reinstalling the game
  • deleting the engine.ini file as it seems to store information surrounding

The really frustrating thing is that only a few people other than myself has this issue and nobody seems to know how to fix it.

Here's the interesting thing: the game seems to not create any cached user details when looking at engine.ini after accepting the terms and conditions:


You can delete this bit of text over and over and over in engine.ini, and have to accept the terms and conditions every time but it just outright refuses to actually make an account.

This game is easily the longest early access I've ever been in.

I ♥♥♥♥ing finally ♥♥♥♥ing fixed it...

In your profile, you need to generate an OAuth 2 key - sign in to with your steam profile, then on the left menu click on API Access then under the OAuth 2 section, generate a token (doesn't seem to matter if it's read only or read+write but I just used the latter just in case) then copy that and open Engine.ini located in C:\Users\Username\AppData\Local\Insurgency\Saved\Config\WindowsClient

In engine.ini there should be a section titled [/script/modkit.modioclient] - if it doesn't exist, launch the game then click on the mods button and it'll then create it. There's a line that says AccessToken - you need to copy the access token into here and it should then let you download maps when you join the server.

edit: ok it seems like I could actually sub to a mod via the in-game mods menu. Even the ratings buttons worked too. When I restarted the game however, just got an infinite loading circle lmao. Then I opened the game later in the day and then I could see the mod list again.

Longest early access game I've ever played