Need help troubleshooting potential network issue / only local gameplay works

I posted this in the #support channel of the official Sandstorm Discord server but haven't made any progress yet:


Sorry if this is not the right place to raise this. When I start Sandstorm, I see the Insurgency Sandstorm logo with my character behind it. He is moving "swaying" for about a split-second before he freezes. It then stays frozen for a good 4-5 minutes. During this time, I can see the RAM increase from 2 GB to 2.5 or even 3 GBs and Task Manager shows as "Not responding". Then the main menu finally loads and my character (and the background) is moving again. I can see in the top left corner than I am connect to Steam (green check), but an orange clock for NWI services ("Connecting to New World Services..."). This never connects how ever long I wait. If I click on the + party button in the top right, the whole game crashes with a popup to send a crash report. If I play Local or Tutorial, NO PROBLEMS at all. I get FPS of 60+ for Medium detail, and 30-50 FPS for High detail. If I try to play online anyway (ignoring the "Connecting to New World Services..." status in the top left), any game mode i choose shows me "Loading playlists..." indefinitely

My system is older: i7-920 at 2.67, 16 GB of RAM, Geforce GTX1080, Windows 10 (1903)
I've tried, uninstalling/reinstalling from Steam, verifying game files, reinstalling Easy Anti-Cheat on its own, running in windowed/fullscreen, disable overlays for both Steam and NVidia, turned off Windows Firewall and real-time protection completely. I opened 27000-27036 for both TCP and UDP on my modem router, rebooted it, tried with/without a VPN. I deleted the folder "C:\Users<username>\AppData\Local\Insurgency\Saved\Config\WindowsClient" and also disabled IPv6 for my network adapter as suggested by someone in the #support channel. Also, I play Insurgency and Day of Infamy without any issues (I have a dedicated DOI linux server in a VM that works just fine too).

I've Googled my symptoms to no avail. I'm hoping someone here just might have seen this issue before. My gut feeling? I feel like the inability to connect to NWI services is what's causing the long delay at the beginning, but I don't know how to troubleshoot that any further. I am so frustrated after hours of troubleshooting... if I have to start packet captures to play this game, I think I'd rather just eat my $15 and leave my honest review online 😞

Thank you for any feedback or suggestions!

I gave in and setup pcaps.

I saw that my requests outbound were sent but never ACK by the NW service. Obviously, the service is up since no one is reporting an issue. So I figure the route back did not reach the original requestor. Sure enough, it's because of my dedicated DOI and Insurgency linux servers.... running on VMs... they have natting that route traffic to the VMs.
Even though I killed VMware and disabled all virtual network adapters, netstat showed that a vmware process was still listening on ports that Sandstorm also shares.
So, my guess is that replies from the NW Services server was dying when the vmware service tried to NAT it to a completely shutdown server.
I guess the only question is why I can play Insurgency and DOI while my VMs are hosting at the same time. They must not overlap inbound ports, and Sandstorm does.
Sigh, I guess I have to change the dedicated server ports that Insurgency and DOI listen on and update my Vmware NAT rules if I want to have the VMs and Sandstorm co-exist on the same machine.