Ongoing Bug - Cannot change back from female to male

Hey ya'll,

This is an ongoing bug and no method I have found online has successfully resolved it. When I first started playing Sandstorm I chose the female security character to play with. I enjoy playing with her, especially as she represents the badass female Kurdish warriors, that said, I am not able to switch back to the Male character. When I do, I get a different set of camo and such, but the character remains female.

Is there a way to reset this?

To quote @Arc:

"This is caused by your old cosmetic preset from Alpha/Beta test.

Firstly go to Steam client, Steam Library, Insurgency: Sandstorm, right-click on it, Properties, Updates tab and in there uncheck "Enable Steam Cloud synchronization..."

Go to %LOCALAPPDATA%\Insurgency\Saved\SaveGames\Profile (AppData is hidden by default in Windows) directory and remove "Cosmetics.json" file.

Once you start the game again, it will recreate the file and will use default config so recreate your desired cosmetic presets.

Once that's done, exit from the game, backup newly created file and re-enable Steam Cloud."


Hey @Aslan14,

Yeah, as mentioned above, can you try this workaround and see if it works?

@chaton & @ham cucumber,

Unfortunately this did not work, and I have tried it before but without turning off synchronization. Even if the Male character is chosen, the voice and body/face are female.

Well I mean it's 2019, you can't just assume your character's gender lmao

@Aslan14 Have you followed the entire list of instructions as posted by @ham-cucumber ?
Namely disabling Steam Cloud and testing it that way before re-enabling it ?

Could you please post a video showcasing the issue ?

Hi Arc,

Yes I followed the full instruction. This has been ongling since the Alpha.

@Aslan14 same here man. Been like this since beta.

@chaton, @arc -

See @MLB7's similar issue. Seems those of us who played early on cannot reset this. Is it possible our cloud profile itself is bugged, such that when we turn cloud synch back on we revert to our Alpha/Beta settings?

@chaton, @arc, @mlb7 -

I have confirmed the bug has to do with the cloud synch. I ran an experiment where I disabled cloud synchronization on Sandstorm, as well as the CTE just to play it safe. I then removed the entire profiles folder, booted Sandstorm, and was delighted to see I have the male character available for the first time since the Alpha. I set him up by unlocking a bunch of XP, exited the game, turned on cloud synch, loaded the game, and once again was stuck with the female character as my only option.

Can you please pass this bug report onto the developers? I also lost a bunch of XP points in this process.

You cannot lose XP by disabling Steam Cloud, XP, Coins and unlocks are handled by our internal backend and are not part of Steam Cloud in any way other than your cached local profile. If anything it's likely a UI bug displaying incorrect cached values.

Now that we know the issue is in Steam Cloud, you may try to enforce files into it manually:

This is done via accessing "...\Steam\userdata\YourUserID\887860\remote\profile" and moving your new/correct files there.
If you did not back up new files, proceed as instructed before however this time, backup your files, do not enable Steam Cloud yet, shut down Steam client and copy new files into that remote directory mentioned above.

Once you start Steam client and enable Steam Cloud, it should force upload that into the cloud.

If not please keep me posted.


@arc, I followed the process as you described, and it did not work. I was able to generate the male character with cloud disabled, copied the profile to the specified folder when not in steam, logged back in, re-enabled synch, and again am stuck with the female male character. I tried this twice.

Seems plausible that the issue is in my cloud profile?

@Aslan14 Have you tried randomizing your cosmetics and saving it as new preset ?
Saving a preset should trigger Steam Cloud upload from local to cloud however i'm not sure if this fixes the issue or if due to already corrupted file it just uploads that.

Another option is to try to use a 3rd party tool to force-upload your correct local files into Steam Cloud.

@arc, @chaton - saving presets did not work the first time, but I realized I forgot to exit steam when copying the new profile. I tried it again, and also copied the profile files into C:\Program Files (x86)\Steam\userdata\18414714\581320\remote\profile.

It worked!

@mlb7, we have out solution.

I was about to try out the female character as hearing her in-game voice lines are super badass, but now I'm hesitant as I don't want to get stuck like that if I end up wanting to change back. Is this still glitched or anything I should know to prevent/fix it?

@Bronbin Please read what is written in the topic you are replying to:

"This is caused by your old cosmetic preset from Alpha/Beta test..."

It's not going to happen if you did not participate in early Alpha/Beta tests of Sandstorm (pre-launch) and it is unlikely to glitch itself if you do not have it glitched already in case you did participate in those tests.

@Arc I didn't partake in that (and I'm kind of glad I didn't seeing the myriad of problems it seems to constantly be creating). Side note this is the first time I got a notification on this site while still online and the sound bleep made me jump lol. Thanks so I guess I should be able to toggle it back and forth but with the number of bugs I've encountered to do with my loadout seeing this as a thing still makes me skeptical.