[PS4] L2/R2 buttons not working! Bug?

Hello guys! I just joined here and I've been trying to get some help to solve an issue, maybe someone here had the same problem.

I got the digital ps4 version. I've been having issues with L2/R2 buttons in three ways:

  • Shortcuts: if I try to assign a sill or item to a shortcut using R2, let's say R2+ square, the game indicates that shortcut is assigned, but if I press the shortcut it'll be like I only pressed Square (regular attack). Curiously, R2+dpad shortcuts work fine!
  • Fury: pressing L2 with focus available will simply do nothing.
  • Menu: whenever I try to change tabs on the menu both L2 and R2 don't work. That way I can't check most of the menu, like sidequests, items, attributes and talents.

I've tested the controller on 3 other games and it works normally, and also tried redownloading and reinstalling the game again but the issue remained.

Did anybody have the same problem? Or anybody currently having the same issue? Thanks!

last edited by megadeds

Canaanyone give me some kind of feedback? Cause honestly I can't play the game like that and I'd like to know if anyone is at least looking at this issue. 😞

Try another controller out.

@cupmuffin If that was an option I would've done that already. 😞 All my friends that own a ps4 live far away from me and buying a new one is out of question, it is too expensive where I live. The controller works 100% fine on every other game, so I don't think that is the problem.

Hello megadeds and sorry you’re experiencing issues with the game.

What is the model of your gamepad ? Which PS4 do you own (OG, Pro or Slim) ?

Regards !

Hello @Focus_Farah !

I own an OG PS4 and the gamepad's model is CUH-ZCT1U (it's the one that came with the PS4).
I've also tried hard resetting it and it didn't work.

I thank you for the reply, hopefully we'll be able to solve this soon. πŸ™‚

Hello, any updates regarding my issue?

It must be your controller or something. Because I am on an OG PS4 (with the original controllers) and the shortcuts you described are working fine for me.

@BlackboltJohnson Well the thing is that honestly, none of my other games have any problem... I've tried looking for people who had the same issue (controller not working on a single specific game), asked around ppl who work in the area and everyone said it's not the controller...

I'm not trying to be dramatic, but PSN won't let me ask for a refund and buying a new controller is just too expensive for me. Minimum wage here is 900, I paid 180 for the game and I will not pay 200-250 for a new controller just because of one single game that I don't even know if I'll enjoy. 😞

last edited by megadeds

I'm having a similar issue, the R2 button is not working at all even though it works fine on any other game, is there a solution? This is driving me crazy

I have the same problem the controllers works perfectly on every other game but in Greedfall the R2 doesn't work. My other controller works fine.