Load-outs Still Not Saving After Game Restart Please Help

Can I please get some help here? Is there a fix? Is it already known? People have been noting this bug since May (https://steamcommunity.com/app/581320/discussions/0/1651045226226155424/)


A link to the discussion about it on Reddit with the only person helping me on this so far, to show how aggravating this bug is. Can I please get any comment of acknowledgement on this?

Today's patch still didn't fix this issue still getting no save to loadouts.. I just want to delete a few too.. please any help devs?

Hey @Bronbin,

Thanks for reaching out to us here. Can you try this?

Main Menu > Customize > Loadouts

Once you customized everything, join a game. Your loadouts should be saved and will not disappear when exiting the game.

@chaton Hi Chaton, thanks for the reply, this works while still in the game but I'm having an issue once the game is restarted - then all my in-game loadouts will reset any and all changes I've made to them - they are stuck in place how they were from about a week ago, and I've tried just about everything to fix this but nothing has worked.. I've verified my game files via steam, backed up my old app-data folder and let the game create a new one - this still didn't fix the issue all my loadouts were still there but upon game restart still all changes are reset. I've even made sure the Profile file in the App data folder where loadouts are saved is not set to read only - still the issue persists (I love to tweak loadouts constantly to try to combinations to keep the game fresh, so this is really game altering for me).

Hey @Bronbin,

Thanks for the further information! I'll pass this on to the team, so they can look into this issue.
Have you played the game during open betas?

Hey @chaton, I started playing it in December right after launch so I don't believe I have anything beta related on my computer. The only things I haven't tried are reinstalling the game completely (though I'm not sure if this would help as from what I've learned so far the loadouts are found in the AppData folder which I've already tried switching out) or trying to install the game on another computer with my same Steam account to see if I could make changes there, though I'm not sure that would even carry over now that I think about it as it would have a different AppData folder.

So anyway I'm pretty stumped at this point 😣 the only recent change I can remember making to my computer was upgrading to Windows 1903 for the second time (previously had rolled back once). And I'm pretty sure the issue started sometime after Update 1.3. and someone replied to my post about it on Steam with the same problem so I'm sure I'm not the only one with this issue at the moment.Thanks again so much for the help on this.

last edited by Bronbin

Can you try to delete your profile.sav in %LOCALAPPDATA%\Insurgency\Saved\SaveGames\Profile?

Hi @chaton, I tried deleting the AppData folder which also deleted and replaced the Profile file which didn't work, but I will try to delete just the Profile now.

last edited by Bronbin

Hi @chaton, I just tried deleting the profile.sav file and the issue still persists 😞

@Bronbin Thanks for letting me know! I'll pass all this information on to the team!

Hi @chaton I just received an email from my support ticket and he had a tip that worked!: -
"There is a conflict between your local files and Steam Cloud ones, in
which case, disable Steam Cloud, launch the game, alter your loadouts,
restart the game and see if it is fixed."
I turned off steam cloud synchronization for Sandstorm made a change and upon restart, it saved finally! My only question now is why this could have occurred and will my game be impacted at all with steam cloud synchronization turned off? ( (I noticed it shows as '249.81 KB stored / 195 bytes available for Sandstorm, did I run out of room?). I'm also worried this will somehow cause some other problem I'm not aware of yet. But thanks again for all the help! And I'll pass this information on to the other forums I've posted about this in for others with this issue.