Community server bug: RespawnDelay, RespawnDPR has no effect.

On Linux, Setting these values has no effect in game.

Bots respawn instantly, Visible in the player list and the server logs. It shows "Pawn being deleted before spawning new one"

Earlier in the logs it spits out the parameters of the official game mode (looks like maybe it overrides them) except this defaults to 20s RespawnDelay, Which its definitively not doing.

Its instant. What am I doing wrong here? I put RespawnDelay and RespawnDPR in the coop section as well as checkpoint in case it was wrong.


These 2 are only used for PVP modes (Push to be more specific) if i recall correctly.

@Arc per the official admin guide they are bot-specific, checkpoint options


@Arc As Joek mentioned these are specifically listed under Coop options;

I tried disabling OfficialRuleset, Same behaviour, Although now there were no log messages mentioning RespawnDelay (set as Official ruleset). Enemy bot spawns were still instant.
I tried enabling cheats disabling XP and VAC and observed same behavior. Enemy bot spawns were instant.
I tried many different settings to be sure they wern't outside some accepted range. Enemy bot spawns were instant.

I referred to the official admin guide through this process.

Grepping RespawnDelay only ever showed up with OfficialRuleset enabled where it spat out the official ruleset params in the log. It was not clear from the logging if this was overriding or not.

I'm a Developer & Engineer by trade so feel free to provide me as technical advice as you can.



Which muppet selected someone contradicting documentation with a complete guess as the correct answer?

@Arc said in Community server bug: RespawnDelay, RespawnDPR has no effect.:

These 2 are only used for PVP modes (Push to be more specific) if i recall correctly.

At some point would you care to do your job? I'm happy to get a refund from steam as lack of support qualifies me for in my country.

Can you imagine how many people are scratching their heads over what appears to be a completely incorrect guide?

I cant begin to describe how modern computer science is ruined by guess based engineering such as what you did here. Its no wonder the game is so buggy.

@Arc also retreattimer is broken i used to have it as retreattimer=999 so they would not retreat not working anymore.

Ive since determined through rcon that the game properties are used even with official rulset spitting out different values.

I think its pretty clear at this point they

A) Wrote the entire admin guide incorrectly
😎 Noone actually knows whats going on
C) Dont give a fuck, This support guy has been on three times answering pointless shit questions instead of explaining if the guide is wrong or not. I'm sure he wrote on most of them "I think, Probably, If I recall, Most likely"... You know.. Boolean values.