Using Rcon to change map always defaults to hardcore.

I'm testing my Rcon app and I've noticed that if I have normal and hardcore maps in my map cycle and try to change maps via the rcon "travel" command the map is always the hardcore version. The only way to choose a normal coop map is via the votemap screen. Is this by design or is it a bug?

Here is the debug code to show you that the correct map choice is being sent via rcon:

@TokaiTele you can specify more than just the scenario to achieve the desired result. Try specifying ?game=Checkpoint. Here's some Ruby code I'm using (not all game modes are accounted for...):

@mapmap = {
  'Canyon'    => 'Crossing',
  'Compound'  => 'Outskirts',
  'Farmhouse' => 'Farmhouse',
  'Ministry'  => 'Ministry',
  'Mountain'  => 'Summit',
  'Oilfield'  => 'Refinery',
  'Precinct'  => 'Precinct',
  'Town'      => 'Hideout'
@inverted_mapmap = @mapmap.invert


map = @mapmap.values.sample
team = ['Security', 'Insurgents'].sample
query = ''
game_mode = server_info['a2s_rules']['GameMode_s']
case game_mode
when 'Hardcore Checkpoint'
  game_mode = 'Checkpoint'
  query = '?game=CheckpointHardcore'
when 'Frenzy Checkpoint'
  game_mode = 'Checkpoint'
when 'Skirmish'
  team = ''
command = "travel #{@inverted_mapmap[map]}?Scenario=Scenario_#{map}_#{game_mode}_#{team}#{query}"
last edited by JoeK5142

thanks @JoeK5142 I'll give that a try and report back when I chance.

@JoeK5142 Thanks for the help. I should've worked it out after they added the parameter for hardcore at the end of the string.

So, here are the two different strings that definitely work on the 'travel' command:
For Normal mode:Oilfield?Scenario=Scenario_Refinery_Checkpoint_Security?game=Checkpoint
For Hardcore mode: Oilfield?Scenario=Scenario_Refinery_Checkpoint_Security?game=CheckpointHardcore

last edited by TokaiTele