Community Server Browser, Unable to View/ Search

I have not been able to play in any custom server since the last update.

When I click "Server Browser," at the top right, it reads "Searching" but the server browser list never appears.
I have tried deleting User Settings, uninstalling/ reinstalling, and verifying game files but no luck. Also tried adjusting the region settings as well.

I can still play in the official servers.

Any suggestions?



last edited by Dr Deep


Try this :

  1. ) Close Insurgency:Sandstorm and return to Desktop

  2. ) Open the main Window of Steam (double clicking on the Steam taskbar icon if Steam is already launched or just Start Steam from Desktop Icon ) , then click on Steam ( left Top ) and then click on Settings.

  3. ) In the new Window choose : In Game ( on the left side - 3rd from Top ) and then click on the setting below of ---> Serverbrowser: Max Pings per minute :
    Choose ----> Automatic ( 3000 )

4.) Click on ---> OK

  1. ) Now start the game again and try it again to find servers on the custom server browser.

It should work now !

Edit : Also ensure that your Windows Firewall and your Router Firewall are not blocking the game !

last edited by GSG_9_LIGHTNING