Extreme performance drop after 1.1.4 Hotfix

My computer specs (laptop):
CPU: I7-8750H 6 cores 2.2Ghz base clock, 4.1 Ghz boost clock (3.9Ghz on 6 cores) 12 threads 9mb cache with Hyper-Threading on
RAM: 8Gb DDR4 2666 Mhz
GPU: GTX 1050 but i always overclock it
HDD/SSD: 1TB WD with 400GB free/ 128GB Kingston m.2 ssd with 300-470 Mb/s read/write speed with having 39gb free (game is installed in ssd)
Note: My computer have a very good heatsink with cpu always around 70 degrees Celsius and gpu is around 60. The Laptop model is MSI GL63 8RC
After the 1.1.4 Hotfix my in-game performance has been dropped to unplayable, it even worst than back in Beta. Last 1.1.4 patch (before the hotfix i got the best performance ever with 65-80 fps with not stuttering and smoothly) before the 1.1.4 patch my game is decent with the same fps average but there are some fps drops and stuttering while using 4x scopes but not much. Now the game is always having hiccups and stutters with average of 55-65 fps. I have noticed that gpu usage is always dropping and to 60-70% a lot even while fps is at 50 fps. When as last patch before the Hotfix i got a solid 95-99% gpu usage. Cpu usage is always around 30-40% as normal. I did tried to delete the config files and reinstall the game but it's still the same and I'm sure that my gpu and cpu is at max performance as i tried others heavy games and my gpu usage is always solid 99% usage. Hope you guys can figure out the problems with the game and keep up the good work!

last edited by MintNatteron

Hey @MintNatteron

Thanks for bringing this to our attention. I'll pass this on to the team!

I have a 1080ti, 16gb ddr4 hyperx gaming ram, i7, 7700, game and os on two different ssd's

and the game runs much worse for me to, I have deleted the config file and also reinstalled from scratch.

all other games run fine no stutter not hitches, all on extreme.

confused as to why 6 months down the line this seems to get worse for some.

last edited by k0872

Me too! i have the same spec as you (except i7 8700k) and its worse than ever

I propose you guys to try out this guide for better performance :

I know it´s just a compromise solution, but it´s better than having bad performance.
The game should be smooth and fluid in general, but sometimes difficulties have to be overcome by developers who are new to the Unreal game engine.

last edited by GSG_9_LIGHTNING

Try minimum graphics settings at 1080p then work your way up.

Just sitting in the menu:

Then launching a map:

Not sure what happened here, but I know with this same rig, CTE played @ 112 FPS just fine. So has the minimum requirements been bumped? Didn't get the memo.

@rpgdodger It's rather to be a performance bug effecting some specific system. But i did tried all settings and the result is still the same with gpu usage droping

@firstcommand Do you have Texture Streaming Pool on High? I see that the game is eating all of your Vram. Try to set it to Low

Change your settings a few times, V-sync on/off, anti-aliasing on/off. Etc.

Little tedious I know but it was happening to me and randomly changing a few settings got the game to behave.

Aside from that, I would say to verify file cache, which I know you probably already did but just in case.

@mintnatteron Not too smart of me having - NOTEXTURESTREAMING in the launch command, but even finding that and removing it didn't solve the problem. Even did a clean reinstall and smoked the configs, still no joy.

What was the problem?

Windows 10 seems to fragment memory in a bad way. From a clean reboot, straight into Steam, launch Sandstorm, works like a charm. So the lesson from this hair-tearing excursion is do not try to use your computer as a normal desktop, then attempt to frag some bots, no workie. I should have remembered this from days of old, but I got so used to being able to run anything I wanted on this machine at any time.

Anyway, problem solved. Fun game. Glad I snagged a copy. Kudos to all the developers that made this one possible.