Fatal error and game not responding on campaign and battles.

cant get into battles in the campaign and the game crashes in some skirmishes even though the specs are above recommended and all drivers are up to date. tried multiple solutions put up regarding the launch options and erasing the save files however nothing worked so far. attached the file with dxdiag and crash.

Hey @marwang25

Are you still having this issue after the April 1st hotfix?
If you could provide any more details regarding where and when exactly you crash, that would be very helpful! Thanks. 🙂

yeah still the same issue after the fix, the game stops responding after i try to do any battle in the campaign.
i am already past the prologue and have done two battles after that but after it freezes and stops responding every time i try to do any battle after. the battles run smoothly and graphical issues but whenever i try to go from the battle screen back to the main menu it also stops responding.

Thanks for the details! I'm not sure I completely understand everything though - you say it freezes and stops responding every time you try to enter a battle. Is this during the loading screen or after? Also, if you can't enter a battle, how does the battle run smoothly?

battles outside the campaign such as 1v1 and online run smoothly.
the lack of response and freezing happens when i try to initiate a battle in the campaign or during loading screens.


Still got that problem.

It's been months now.

Hi @goldstrike

Thanks for providing your crash log. Is this still happening after yesterday's update?

Lol. I can't test that theory. I have a new crash related to Easy.

Apparently the update rewrote a file and Easy Anti-Cheat is upset about it.

Give me some time to play with it and I will post the logs.