Consistent crashing Data attached

Crashed consistently through the prologue. Set the complete Prologue value to True to see if it was purely a prologue issue, crashes consistently during the imperial campaign. Same message every time. Pic of Crash seems too large to upload, transcribed to Word Doc, same message every time. Sending most recent crash log, have dozens.


Hey @Battlefiend

Are you still having this issue after the April 1st hotfix?
If you could provide any more details regarding where and when exactly you crash, that would be very helpful! Thanks. 🙂

OK, yes still an issue after April 1st Hotfix, which is the 49MB update that just downloaded, I'm assuming. Ran the prologue and, as usual, the 1st mission runs fine. Upon its conclusion, I saw the cut scene movie play. It completes, then takes me to a loading screen. Game failed during that loading screen. The music stopped playing, then shortly after, the screen went blank, then the following report showed:

h] [Line:158]
FWindowsReadRequest GetOverlappedResult failed code = 17!

I would like to point out that the previous several times it had crashed, before the hotfix, the Line: was 153, this time it was 158. I'm not sure if that's useful, but that's something that's changed. I will now attempt to play the imperial campaign, having utilized the method you posted on another thread just to verify whether or not the hotfix has fixed the main campaign, and just hasn't yet worked for the prologue. I will report back the results.

Game crashed during imperial campaign. I loaded into the autosave at the end of turn 2. Turn 3 starts, I upgrade the infrastructure as instructed, then the game "releases" me to begin managing my own campaign. Campaign map appears to function just fine, i.e. I could move fleets from planet to planet, I could purchase ships, and I could upgrade planetary infrastructure. The first time I tried to initiate a combat, on Turn 4, the game crashed with the above message. Specifically, it crashed on the fleet screen where it was showing me my ships on the left and the enemy ships on the right. The crash also referred to Line:158 (see previous reply) In addition, once I "OK'd" the windows fatal error message, a SECOND message came up, which I have never seen before during any of the previous 10 crashes, which said:

EASY Anti-Cheat

Unknown file version (D:\SteamLibrary\steamapps\common\Battlefleet
Gothic Armada

Hope this helps. I'm currently deployed to the middle east right now, I have to pay for internet by the GB, It cost me a decent amount of money to spring for the 45GB download of this program, after the initial outlay for the software purchase. I'm hoping to get a decent experience out of this, having thoroughly enjoyed myself on the First Gothic Armada. Actually, to be honest, I've had a solid experience with every Warhammer game I purchased over the past 14 years or so, which is something like 12 titles, all the Dawn of War's, their expansions, the space hulks, the Space marine FPS, the first Total war, (still wishlisting the 2nd one)and this is the first time I've had an issue, so I'm grateful for that.

Hi @Battlefiend
Thank you so much for this information. The team will take a look at this and try to find a solution asap!