Cutscenes doesn't Load. AT ALL.

Problem; Game runs well when in gameplay.
But Any and ALL cutscenes doesnt load, AT all. its like the game FAIL to understand its supposed to load the cutscenes.
I can skip them and play the game, but that destory the entire reason to play a STORY campaign!
Its been like this since launch in January, WHEN will this problem be fixed? I KNOW im not the only one with this problem.

Descpition of what happens:
I load game, no problem. I go to campaign. I will play Prolouge and click on start campaign. and then its stuck until i SKIP the cutscene. Waiting doesnt work, i tried that for 20 min and then gave up.
Reinstall game doesnt fix it. Tried it 2 times.
Drivers is upto date. ALL OF THEM YES.
Computor runs a AMD RX 580 and an AMD 1600X processor on Win7 64-bit with 16 GB ram and on SSD driver, so it should not even sweat on this game.

So game devs, what is the problem here?
I mean, the dead primarchs are spinning in their graves so fast they could power the golden throne at this point at this problem, a game that cost 40 euro fails to load video files? Seriously?
You never had this problem in BFG A 1, so what went wrong in A2?

/Fleet Master Profe MacKnight of the GoT.

Hi @ProfeMacKnight,

can you try to reinstall Window's media feature pack ?
It seems to have worked for a fellow player who encountered this issue as well.

Let me know !