[Known issue] Fatal Error after pressing end turn

As the title says I encountered a fatal error during the end turn. I tried restarting the game and repressing end turn but it happened again. Any file that I should provide to allow you to investigate the issue? How do I get such file?

Edit: Maybe I understood what caused it. I had 2 fleets parked in a system where a scripted mission takes place but didn't do the mission. I reloaded an older game and didn't go to that system, it works fine for now.

Edit 2: What I described happened during a necron campaign. I tried to do the same during an imperial campaign, but had no problems there. I parked my good old Spire in a scripted mission system, didn't start the mission and ended the turn expecting the crash to happen, but the crash didn't happen.

last edited by Focus_TomW

Hi, in what campaign are you playing ?

This has happened to me as well.
The setting is the end of turn 29, after reaching the Agrippina in that turn. Hitting end turn causes the first session of AI to take their turns and once it reaches the Necron NPCs the game freezes and crashes. Loading the save before does not seem to help the problem.


Necron campaign, specifically on turn 30.

Just gives me a fatal error every time.

I have the same problem. At turn 30 the game just crashed after ending the turn. (Playing necron) I even replayed half the turn aka the battle, to see if it would change anything. It still crashed.

Was it the white scars mission? I'm having a similar problem currently, but I'm parked with two fleets in an adjacent system... I've attached my dump file. 0_1548443768644_UE4Minidump.dmp

last edited by emraldis

@focus_tomw Also having this issue. It's the turn after the first spec op in the agripinaa sector. The camera goes to the first sector for the AI's turn, which would normally be chaos and imperial only. However, it shows every faction taking a turn, including necron, which is when the crash happens. Hope this helps.

yeah have same issue in Necrons campaign in Agripinaa sector Main Mission, pls fix

I got the same fatal error : The UE$-Battle Fleet Gothic Armarda 2 Game has crashed. All of this after a end turn as the Necrons. Turn 17. I started with anoter save I had before and got the same error at the same turn, just after being at the 3rd sector.

This is a known issue of the Necron campaign and the devs are working on it !

@focus_tomw thank you! So you would suggest me to wait a little bit before continuing the Necron campaign? Are the other 2 fine for now?

I would indeed suggest that you wait for the fix and play one of the other two campaigns in the meantime

Don't know how much this'll help, but I've noticed the turn order always switches to the 'necron' turn in the AI turn order (you're the one playing the necrons, so that should probably not be there) right before it crashes.