Campaign Issue (Selecting Admiral Sprire's fleet)

Game has just updated from being released today and I went to play the campaign. During BFGA2 and currently, I am unable to select Admiral Spire's fleet at the very first sector when it is trying to teach me how to select the fleet. F3 or hitting the button in the upper right only reopens the Systems tab, which is also the only way I can select the first system as well. Clicking on the actual sector does nothing. Mouse and clicking is working though for everything else. I can select Menu options, close the tool tips, and select most other things on the screen, but not the fleets or sectors.

I have this exact issue too, pls someone help as we cannot play the campaign at all because of this roadblock!

Hello both,

Thank you for pointing this out! I'll forward this to the team!

I tried the 'verify game files' process in properties and I changed my mouse neither worked. 😞

Also tried changing from fullscreen to windowed and changed resolution, nothing has worked

Maybe the devs could change the script at that point so you can select the Admiral with a shortcut?

Currently I'm blocked and therefore can't play the other campaigns either. When you have waited through the beta for this to happen is really frustrating as I'm sure you are aware. At least I can play multiplayer battles I guess.

Can we get a rough timeframe on this?

I have the exact same issue and I cannot play the game due to this.

Thank you Hjalfnar_HGV - I deleted the save files but that didn't work so I then uninstalled the game again and used a search to delete absolutely everything to do with the game, folders, files, I use to Hard drives so it was I think the game on D drive and the local files and saves on C. Switched off the pc. Turned back on and installed including the latest beta from scratch (I had installed the latest beta earlier but it didn't work). I tried again and had the same issue.

So I went to:


Opened the Game.ini file

Change the following from false to true:


This time FINALLY it has worked !!!!

I have tried all of this and still have the same issue. This allowed me to begin the other campaigns, but still have the same issue once I get to the Sector screen and trying to select systems or ships. It is odd as I can use the cursor to select and do just about anything else in game and on the map. The only way I can select the system is by opening the system drop down and selecting the system asked to select. Then I can select the point of interest on the sector map, but when it asks for me to select Admiral Spire's fleet, it will highlight if I mouse over, but can not select it. Starting to feel that I am missing out on the full game as I can only play Multi-Player or Skirmish games, very sad.

Is there any way to know if this is something that will be worked on, or should I find alternate solutions?