Cannot purchase items in the customization menu

I cannot purchase cosmetic items and am currently stuck at 1,000 credits.
I suspect this occurred after purchasing the black leather gloves for my insurgent character.
Here is a video demonstrating the issue:
Youtube Video

last edited by InsanelyOrange

Hi InsanelyOrange!
I had the same issue yesterday. It turned out I already purchased too many items that I didn't have any credit left. Even though the credit count was on 800. After a refresh/restart the game updated my credit count and it adjusted it too 100.

Does this maybe help?

I had the same issue trying to buy the combat pants for security forces. The same empty box behind the buy box appeared as well. I tried a few times and ended up losing 400 points with nothing unlocked

Thanks for the reply. I tried restarting the game after the issue but it did nothing. However I noticed today after launching the game that the issue is fixed.

I'm getting this same issue - on top of my money being seemingly glitched, I'm not sure if I stopped earning money after a certain rank but it's been 100 for a few ranks despite saying that I've received another 100, I've restarted and everything but I'm just not earning money, it's been two ranks.
This is on top of losing 400 earlier that I was going to use for a torso piece.