MudRunner Editor corrupting file/data?

Since today i had a really annoying issue who make the Editor unusable,some files(xml,mesh,etc) are uploaded even though they don't exist or are hiden in the mod folder of the editor.
Also we have some random file suppressed from the mod folder too.
Right now we are two person with the same problem.
Is there a specific folder where the editor is potentially using as temp/cache folder beside appdata and the main folder?
Is there some kind of cloud based data?

We tried the following:
-uninstall the editor
-suppress the mod folder
-suppress the mod from the workshop
-wipe appdata mudrunner folder and editor folder
-steam file check
-tried to upload a basic truck didn't work and my mod was still uploaded
-tried to upload empty folder to steam my mod is still present untouched😵

Now the whole mod is corrupted in the workshop and missing some file, and have some i removed on previous upload.

Also on a side note when a mod is uploaded there is no real information about the success of the upload, the small windows with a progress bar is progressing then shutdown and that s it ,nothing in the output section either but you can still have a corrupted upload.
Any answer on this would be appreciated.

last edited by Raphael

This may be because of the cache folder being shared by the old ST editor and the new MR editor again. I just noticed this today while trying to load some of my models and seen that PZ changed the cache folder back to the old ST editor cache folder again. So if there are any old models in the from ST, you'll get errors because of the old models.

I can't imagine why he'd go back to the old cache folder again after he created a new cache folder for the MR editor. Hopefully he'll fix it again.

The temp fix is to go into \AppData\Roaming\SpinTiresEditor\MeshCache and delete the models that are in there and let them get rebuilt again by the MR editor. That's what worked for me.

Hello @Raphael and @Tattoo

Thank you for reporting us this issue. The team is investigating now.

I just gave up spent a lot of hours trying on this without any result, and also no i don't have any remaning folder from Spintires and made sure of that,i think it s related to steam cloud or something who keep information and shouldn't.
Also the notepad ++ plugin refuse to work properly too,spend a lot of time trying to find a solution, i found somewhat a fix but it s just not reliable enough to work with.
The goal was to upload a truck model made from scratch but if you have to spend more time on troubleshooting and wipe out each time all your xml and rename everything because somewhere there is something reading up your setting and messing eveyrthing up it s a nightmare specialy when there is a lot of addon involved.

On a side not i suspect win10 and notepad ++ and his plugin to not get along very well.
I speak about win 10 updated not six month late because some of them can have some effect on Notepad ++ and their addon.

last edited by Raphael