[Fixed] Game crashes before I can get to any settings

Either right before the "I agree" box comes up, or right after I click I agree the game crashes to desktop.

Sometimes I get at "Fatal Error" box, sometimes I do not. Either way I cannot interact with it, it just goes to desktop.

I cannot even get to the settings to try windowed or any other display setting 😞

I will be happy to tweek an ini or settings file but I don't want to go rooting around.

Please let me know if there is anything I can do to fix it.


last edited by Focus_Camille

You are not the only one. I got the same issue...

I cannot start the game too


It is working well now

last edited by Makron

Same. Game loads well untill the "I agree" box and then crashes after a few seconds.

Edit: Nevermind, I erased the game, the reinstalled in another drive and now it works. It might have something to do with the fact I still had some files from the closed beta.

last edited by Ansark


please delete the folder BattlefleetGothic2 located at C:\Users\USERNAME\AppData\Local with your game closed.
Let me know if it helps !

This fix worked for me. Thank you!