Server wont show up in server browser

So I just updated my server to the newest patch after the 14th update. It was running for a day or so on the old version.

I used steamcmd to update it, then restarted the server. But after the update and restart, it wont show up in the server browser.

I have tried a bunch of tweaks to the start script but nothing changes. Using the same start script I had working before the 14th update it still wont show up.

Is there a delay due to running the server for a day without updating? Is there something that changed in the update regarding the start script or the commands available on the Game.ini?

I cant figure out why it wont work anymore. The server appears to start fine, and gives a similar output to what it did before the update, and it looks like it should be working, but it just wont show up in the browser.

Any help would be appreciated.

Tried running
app_update 581330 validate
But that didnt fix it

Also tried restarting the whole vps but that didnt work either

last edited by KroniK907


I had run force_install_dir when I set it up last week. You have to run force_install_dir every time you update, or it will not update the correct version.

After running the force_install_dir command in steamcmd and then running the app_update command, the server now shows up in the list.

Yes, you need to login, specify path, specify appID and what you want to do with it every time.

SteamCMD is capable of running with scripts to make this just one-click job, see: