everything floats ??

first time with editor, Nix's tutorials are Great! all of a sudden 'Everything' is floating.. i do not think i did anything, at all.
I was waiting for 'Rebuild Terrain' to finish (5 to 8 mins, why so long?) then i noticed the 'floating stuff'. Any thoughts or solutions? Please.
0_1515273091639_floating stuff.PNG
0_1515273110515_floating stuff2.PNG

Is this happening AFTER the rebuilding terrain has finished? If you start a new map, place a garage object on the ground, where does that appear?

it has only happened this once.. i have been working on this for 3 days and it opened properly each time, i've gone back to it.
Floating Map: I did try closing the map and Editor, also exit steam. upon re-opening all, everything is still floating.
New Map: just tried a New Map. everything was fine. Until i 'Rebuild Terrain' and.... now it's all floating. Even the garage locator is floating.. UPDATE; IF I GOTO THE GEOMETRY TAB IT ALL GOES TO THE PROPER PLACE.... AS SOON AS I HIT A DIFFERENT TAB IT GOES BACK TO FLOATING??
0_1515280433898_did iy again.PNG

last edited by rufus

Disable steam overlay in game options.

Might find something useful in this thread .
Heh, @blasc beat me to the punch... 🙂

last edited by Mexican_420

This saved my sanity...
I was just about to uninstall whole editor just because of this problem.
Just tell me, how you found up, that something such random as steam overlay may caused this?

I found the fix posted by another user here in the forums. 🙂

i did not have the overlay on.. i Did have the FPS display on.. turned it off and made a new map No floating Yet.. (the FPS thing didn't work anyways).
The map that that started floating , is still floating after the changes made..haven't been on yet this morning.. Rufus

i have my fps on from nvida geforce but doesnt cause any issues i did turn the overlay off but never come across floating like that

I tried using the 'Steam fps counter'. i have a shit gpu so there are no options or settings.
And i have an HP All-in-one . so i think that i am going to have to get either an external gpu (no cheap venture, same $ as a reasonable tower) or a new PC.
ALSO the test map from yesterday is still Not Floating. !!

Ok, now I feel embarrassed...
But still, such a random thing. Its like closing window in bedroom to improve FPS...

@rufus, ya know what, that kinda happened to me but I don't remember if I rebuild the terrain or not. What I noticed tho was that the camera was zoomed in too far into the ground and I seen basically the same thing. I zoomed back out and it was correct. Dunno if that's your problem but worth a try. Hope ya figure it out.

@tattoo @Sodoma I found this issue a wayy long time ago when Smed was making Moab on the old ST. Some patch steam made caused this issue.

thanks guy's, for all the info! just a quick ?.. can i turn Off all the labels?
0_1515348886111_too many labels.PNG