I have wasted hours and hours of searching but to no avail. I hoped they could provide me with a solution fast enough or i will consider a refund.
Specs : GTX 1080 OC , I7-7820HK @4.3GHZ , 32Gb RAM DDR4
Solutions tried:
-Restart PC after launching game (didn't work)
-Restart game/Steam (didn't work)
-Wait a bit (didn't work but this is stupid, i would rather know the cause of the problem and documented the issue and trying to solve rather than "wait for a few seconds", this just shows laziness)
-Check Firewall settings( Allow all and still doesn't work )
-Check if anything has hooked on the game(Had disabled Discord,Nvidia Highlights,Steam overlay) (I have used Process Explorer to check and there is nothing hooking on the process) (didn't work)
-Check this page : https://forums.focus-home.com/topic/3208/unable-to-sign-in-to-new-world-services-error/3 by @alexblonski (didn't work not because of the game but of the inconsiderate community supporter , he has no idea that we don't have enough permissions)
Hope the devs had some words about this problem because I am deeply disappointed with the support 😞